pass --enable-all configure flags from debian/rules to build all packages
authorAndrei Zavada <johnhommer@gmail.com>
Sun, 3 Jan 2016 16:44:20 +0000 (18:44 +0200)
committerAndrei Zavada <johnhommer@gmail.com>
Sun, 3 Jan 2016 16:45:48 +0000 (18:45 +0200)
debian/rules

index 95f91ee65321614d555bbd34c0013f081f9d9cc7..eea62baaf50334afc63e48ca6774a0b1cb222dd9 100755 (executable)
@@ -9,6 +9,9 @@ DEB_BUILD_OPTIONS = parallel=4
        dh $@ --with autoreconf --parallel
 #      dh $@ -plua-cnrun --buildsystem=lua --with lua
 
+override_dh_auto_configure:
+       dh_auto_configure -- --enable-tools --enable-lua-api-docs
+
 # Perhaps I didn't try hard enough, but there was a conflict between
 # upstream's own, independent way to install Lua module as
 # /usr/lib/lua/5.x/cnrun.so, and Debian's recommended, using